Manuel : Interface/LTE

S’applique à RouterOS:Manuel : Interface/LTE

v6+,v5.12+

Contenu

1

Sommaire

2

Client LTE

2.1

Propriétés

2.2

Profils APN

2.3

Scanner

2.4

Commande Infos utilisateur

2.4.1

Propriétés (jusqu’à 6,40)

2.5

Commande de l’utilisateur au chat

3

Exemple de configuration rapide

4

Exemple de transfert

5

Exemple de double SIM

6

Trucs et astuces

6.1

Trouver l’emplacement de l’appareil à l’aide des informations de cellule

6.2

Utiliser le verrouillage cellulaire

6.3

Moniteur de cellule

7

Dépannage

7.1

Bande de verrouillage sur Huawei et autres modems

7.2

Modems mPCIe avec appareils de la série RB9xx

7.3

Mise à niveau du micrologiciel du modem

7.4

Éviter la limitation de la vitesse de connexion

7.5

Déverrouillage de la carte SIM après plusieurs tentatives erronées de code PIN

Sommaire

Emballer:

système

Prise en charge des cartes de type mode Direct-IP uniquement.La prise en charge de MBIM est disponible dans les versions RouterOS v7 et le pilote MBIM est chargé automatiquement.Si le modem n’est pas reconnu dans RouterOS v6 – Veuillez le tester dans les versions v7 avant de demander une assistance dans RouterOS v6.

Pour activer l’accès via une interface PPP au lieu d’une interface LTE, changez le mode IP direct avec

/port firmware défini ignore-directip-modem=yes

commande et un redémarrage.Notez qu’en utilisant le mode d’émulation PPP, vous n’obtiendrez peut-être pas les mêmes vitesses de débit qu’en utilisant le type d’émulation d’interface LTE.

Avertissement:

Dans RouterOS v7, le paramètre ignore-direct-modem est déplacé sous

/modem carte routeur système

menu

Client LTE

Sous-menu :

/interface lte

Propriétés

Biens

La description

autoriser l’itinérance

(

oui |non

;Défaut:

non

)

Activez l’itinérance des données pour vous connecter aux fournisseurs de données d’autres pays.Tous les modems LTE ne prennent pas en charge cette fonctionnalité.Certains modems, qui ne prennent pas entièrement en charge cette fonctionnalité, se connecteront au réseau mais n’établiront pas de connexion de données IP avec

autoriser l’itinérance

réglé sur non.

profils-apn

(

chaîne de caractères

;Défaut:

défaut

)

Quel profil APN utiliser pour cette interface

bande

(

liste d’entiers

;Défaut:

“”

)

Bande de fréquence utilisée en communication

Bandes et bandes passantes LTE

commenter

(

chaîne de caractères

;Défaut:

“”

)

Nom descriptif d’un élément

désactivée

(

oui |nonManuel : Interface/LTE

;Défaut:

Oui

)

Que l’interface soit désactivée ou non.Par défaut, c’est désactivé.

Adresse Mac

(

MAC

;Défaut:

“”

)

Numéro de contrôle d’accès au média d’une interface.

modem-init

(

chaîne de caractères

;Défaut:

“”

)

Chaîne d’initialisation du modem (commande AT qui sera exécutée au démarrage du modem)

mtu

(

entier

;Défaut:

1500

)

Unité de transmission maximale.Taille maximale des paquets que l’interface LTE pourra envoyer sans fragmentation des paquets.

Nom

(

chaîne de caractères

;Défaut:

“”

)

Nom descriptif de l’interface.

mode réseau

(

3g |gsm |lte

;Défaut:

3g, gsm, lte

)

Sélectionner/forcer le mode pour que l’interface LTE fonctionne avec

opérateur

(

entier

;Défaut:

“”

)

utilisé pour verrouiller l’appareil à un opérateur spécifique Le numéro PLMN complet est utilisé pour le verrouillage composé de MCC+MNC.

Codes PLMN

épingler

(

entier

;Défaut:

“”

)

Code PIN de la carte SIM.

Profils APN

Tous les paramètres liés au réseau sont déplacés sous les profils, à partir de RouterOS 6.41

Sous-menu :

/interface lte apn

Biens

La description

add-default-route

(

oui |non

)

S’il faut ajouter une route par défaut pour transférer tout le trafic via l’interface LTE.

apn

(

chaîne de caractères

)

Nom du point d’accès du fournisseur de services

authentification

(

pap |gars |rien

;Défaut:

rien

)

Protocole autorisé à utiliser pour l’authentification

distance-route-par défaut

(

entier

;Défaut:

2

)

Définit la valeur de distance appliquée à l’itinéraire par défaut créé automatiquement, si

add-default-route

est également sélectionné.L’itinéraire LTE par défaut est avec la distance 2 pour préférer les itinéraires câblés au LTE

type ip

(

ipv4 |ipv4-ipv6 |ipv6

;Défaut:

)

Type de PDN demandé

interface ipv6

(

;Défaut:Manuel : Interface/LTE

)

Interface sur laquelle annoncer le préfixe IPv6

Nom

(

chaîne de caractères

;Défaut:

)

Nom du profil APN

numéro

(

entier

;Défaut:

)

Numéro de profil APN

interface-passthrough

(

;Défaut:

)

Interface pour passer la configuration IP (active le passthrough)

passthrough-mac

(

MAC

;Défaut:

auto

)

Si défini sur auto, apprendra le MAC à partir du premier paquet

le mot de passe

(

chaîne de caractères

;Défaut:

)

Mot de passe utilisé si l’un des protocoles d’authentification est actif

utiliser-pair-dns

(

oui |non

;Défaut:

Oui

)

Si défini sur oui, utilise le DNS reçu de l’interface LTE

utilisateur

(

entier

)

Nom d’utilisateur utilisé si l’un des protocoles d’authentification est actif

Scanner

Il est possible de scanner les interfaces LTE avec

/interface lte analyse

commander

Propriétés disponibles en lecture seule:

Biens

La description

durée

(

entier

)

Durée de l’analyse en secondes

intervalle d’arrêt sur image

(

entier

)

temps entre l’impression des données

numéro

(

entier

)

Numéro ou nom de l’interface

Commande Infos utilisateur

Il est possible d’envoyer une commande spéciale “info” à l’interface LTE avec

/interface lte info

commander.

Propriétés (jusqu’à 6,40)

Biens

La description

commande-utilisateur

(

chaîne de caractères

;Défaut:

“”

)

envoyer une commande à la carte LTE pour extraire des informations utiles, par exemple avec des commandes AT

commande utilisateur uniquement

(

oui |non

;Défaut:

)

Commande de l’utilisateur au chat

Il est possible d’envoyer une commande “at-chat” définie par l’utilisateur à l’interface LTE avec

/interface lte au chat

commander.

[admin@MikroTik] > /interface lte at-chat lte1 input=”AT*mrd_imei\?”sortie: *MRD_IMEI:356159060388208OK

Vous pouvez également utiliser la fonction “at-chat” dans les scripts et affecter la sortie de la commande à la variable.

[admin@MikroTik] > :global “lte_command” [/interface lte at-chat lte1 input=”AT*mrd_imei\?”as-value ] [admin@MikroTik] > :put $”lte_command”output=*MRD_IMEI:356159060388208OK

Exemple de configuration rapide

Commencez par les paramètres réseau –

Avertissement:Manuel : Interface/LTE

Ce guide concerne les versions de RouterOS à partir de 6.41

Commencez par les paramètres réseau – Ajoutez de nouveaux paramètres de connexion sous le profil LTE apn (fourni par le fournisseur de réseau):

/interface lte apnadd name=profile1 apn=phoneprovider.net authentication=chap password=web user=web

Sélectionnez le profil nouvellement créé pour la connexion LTE:

/interface lte set [trouver] apn-profiles=profile1

L’interface LTE doit apparaître avec l’indicateur (R) en cours d’exécution:

[admin@MikroTik] > /interface lte print Flags : X – désactivé, R – en cours d’exécution 0 R name=”lte1″ mtu=1500 mac-address=AA:AA:AA:AA:AA:AA

Depuis RouterOS=>6.41 le client DHCP est ajouté automatiquement.S’il n’est pas ajouté, ajoutez manuellement un client DHCP à l’interface LTE:

/ip dhcp-clientadd default-route-distance=1 disabled=no interface=lte1

Si nécessaire, ajoutez NAT Masquerade for LTE Interface pour accéder à Internet sur le réseau local:

/ip firewall natadd action=mascarade chain=srcnat out-interface=lte1

Une fois l’interface ajoutée, vous pouvez utiliser la commande “info” pour voir quels paramètres client ont acquis (les paramètres renvoyés dépendent du périphérique matériel LTE):

[admin@MikroTik] > /interface lte info lte1 une fois statut : appel en courspin-status : aucun mot de passe requisfonctionnalité : fullfabricant : Huawei Technologies Co., Ltd.modèle : ME909u-521révision : 12.631.07.01.00current-operator : vodafone EScurrent- cellid : 44436007access-technology : Evolved 3G (LTE)signal-force : -79 dBmframe-error-rate : n/aearfcn : n/aimei : 860461024123456imsi : 234012555034981uicc : n/arssi : -79dBmrsrp : -109dBmrssrq : -13dBmrssrq : -13dBmrssrq : -13dBmrssrq : [admin@MikroTik] >

Exemple de transfert

À partir de RouterOS v6.41, certaines interfaces LTE prennent en charge la fonction LTE Passthrough où la configuration IP est appliquée directement au périphérique client.Dans ce cas, le micrologiciel du modem est responsable de la configuration IP et le routeur est utilisé uniquement pour configurer les paramètres du modem – APN, technologies réseau et type IP.Dans cette configuration, le routeur n’obtiendra pas la configuration IP du modem. Le modem LTE Passthrough peut transmettre à la fois les adresses IPv4 et IPv6 si cela est pris en charge par le modem. Certains modems prennent en charge plusieurs APN où vous pouvez transmettre le trafic de chaque APN à un routeur spécifique interface.

Le passthrough ne fonctionnera que pour un seul hôte.Le routeur détectera automatiquement l’adresse MAC du premier paquet reçu et l’utilisera pour le Passthrough.S’il y a plusieurs hôtes sur le réseau, il est possible de verrouiller le Passthrough sur un MAC spécifique. Sur l’hôte du réseau où le Passthrough fournit l’IP, un client DHCP doit être activé sur cette interface. pas possible de se connecter au routeur LTE via l’adresse IP publique lte ou à partir de l’hôte utilisé par le passthrough.Il est suggéré de créer une connexion supplémentaire du routeur LTE à l’hôte à des fins de configuration.Par exemple, l’interface vlan entre le routeur LTE et l’hôte.

Pour activer le Passthrough, une nouvelle entrée est requise ou l’entrée par défaut doit être modifiée dans le menu ‘/interface lte apn’

Avertissement:

Le passthrough n’est pas pris en charge par tous les chipsets.

Exemples.

Pour configurer le Passthrough sur ether1:

[admin@MikroTik] > /interface lte apn add apn=apn1 passthrough-interface=ether1[admin@MikroTik] > /interface lte set lte1 apn-profiles=apn1

Pour configurer le Passthrough sur l’hôte ether1 00:0C:42:03:06:AB:

[admin@MikroTik] > /interface lte apn add apn=apn1 passthrough-interface=ether1 passthrough-mac=00:0C:42:03:06:AB[admin@MikroTik] > /interface lte set lte1 apn-profiles=apn1

Pour configurer plusieurs APN sur ether1 et ether2:

[admin@MikroTik] > /interface lte apn add apn=apn1 passthrough-interface=ether1[admin@MikroTik] > /interface lte apn add apn=apn2 passthrough-interface=ether2[admin@MikroTik] > /interface lte set lte1 apn -profil=apn1,apn2

Pour configurer plusieurs APN avec le même APN pour différentes interfaces:

[admin@MikroTik] > /interface lte apn add name=interface1 apn=apn1[admin@MikroTik] > /interface lte apn add name=interface2 apn=apn1 passthrough-interface=ether1[admin@MikroTik] > /interface lte set lte1 apn-profiles=interface1[admin@MikroTik] > /interface lte set lte2 apn-profiles=interface2

Exemple de double SIM

Pour certaines cartes avec deux emplacements SIM connectés au même emplacement de modem (comme LtAP mini, ltAP), il est possible d’alterner entre les fournisseurs de téléphonie mobile.Suivez ce lien –

Application double SIM

, pour voir des exemples sur la façon de modifier l’emplacement SIM en fonction de l’état d’itinérance et au cas où l’état de l’interface est en panne à l’aide des scripts et du planificateur RouterOS.

Trucs et astuces

Ce paragraphe contient des informations sur des fonctionnalités supplémentaires et des cas d’utilisation.

Trouver l’emplacement de l’appareil à l’aide des informations de cellule

Sur les appareils utilisant la carte de version internationale R11e-LTE (kit wAP LTE), des informations supplémentaires sont fournies sous la commande info (à partir de 6.41rc61)

courant-opérateur : 24701 lac : 40 courant-cellule : 2514442

Biens

La description

opérateur actuel

(

entier

;Défaut:

)

Contient MCC et MNC.Par exemple : current-operator : 24701 passe à : MCC=247 MNC=01

lac

(

entier

;Défaut:

)

indicatif régional d’emplacement (LAC)

cellule-courante

(

entier

;Défaut:

)

Numéro d’identification de la gare

Les valeurs peuvent être utilisées pour rechercher un emplacement dans les bases de données:

Recherche d’identifiant de cellule

Utiliser le verrouillage cellulaire

Il est possible de verrouiller les modems R11e-LTE, R11e-LTE6 et R11e-4G et les appareils équipés sur la tour LTE exacte.La commande LTE info fournit des informations sur la tour cellulaire actuellement utilisée:

phy-cellid : 384 earfcn : 1300 (bande 3, bande passante 20Mhz, cqi 8)

Biens

La description

phy-cellide

(

entier

;Défaut:

)

Identification physique des cellules (PCI) de la tour cellulaire actuellement utilisée.

earfcn

(

entier

;Défaut:

)

Numéro de canal de fréquence radio absolu

L’emplacement exact de la tour ainsi que les bandes disponibles et d’autres informations peuvent être obtenus auprès de l’opérateur mobile ou en utilisant les services en ligne:

CellMapper

En utilisant ces variables acquises, il est possible d’envoyer une commande AT au modem pour le verrouiller à la tour au format actuel:

pour R11e-LTE et R11e-LTE6

AT*Cell=,,,, où : 0 – Cellule/Fréquence désactivée1 – Verrouillage de fréquence activé2 – Verrouillage de cellule activé0 – GSM1 – UMTS_TD2 – UMTS_WB3 – LTEPas utilisé, laissez ce blankearfcn de lte infophy-cellid de lte info

Pour verrouiller le modem sur la tour précédemment utilisée, at-chat peut être utilisé:

/interface lte at-chat lte1 input=”AT*Cell=2,3,,1300,384″

Pour R11e-LTE, tous les verrous activés sont perdus après le redémarrage ou la réinitialisation du modem.Les données cellulaires peuvent également être recueillies à partir de “cell-monitor”.

Pour que le verrouillage cellulaire R11e-LTE6 ne fonctionne que pour la bande principale, cela peut être utile si vous avez plusieurs canaux sur la même bande et que vous souhaitez le verrouiller sur un earfcn spécifique.Notez que le verrouillage cellulaire n’est pas spécifique à une bande et pour la bande ca, il peut également utiliser d’autres bandes de fréquences, sauf si vous utilisez le verrouillage de bande.

Utilisez le verrouillage cellulaire pour régler la bande principale sur le 1300 earfcn et utilisez le deuxième canal pour la bande ca:

/interface lte at-chat lte1 input=”AT*Cell=2,3,,1300,138″

Maintenant, il utilise le earfcn:1300 pour le canal principal:

bande primaire : B3@20Mhz earfcn : 1300 phy-cellid : 138 ca-band : B3@5Mhz earfcn : 1417 phy-cellid : 138

Vous pouvez également le régler dans l’autre sens:

/interface lte at-chat lte1 input=”AT*Cell=2,3,,1417,138″

Maintenant, il utilise le earfcn: 1417 pour le canal principal:

bande primaire : B3@5Mhz earfcn : 1417 phy-cellid : 138 ca-band : B3@20Mhz earfcn : 1300 phy-cellid : 138

Pour R11e-LTE6, les informations de verrouillage de cellule du modem ne seront pas perdues après le redémarrage ou la réinitialisation du modem.Pour supprimer le verrouillage cellulaire, utilisez la commande at-chat:

/interface lte at-chat lte1 input=”AT*Cell=0″Manuel : Interface/LTE

pour R11e-4G

AT%CLCMD=,,,,AT%CLCMD=1,1,3250,244,\”24705\”où :0 – Cellule/Fréquence désactivée1 – Verrouillage de cellule activé :0 – Enregistrer le verrou pour la première analyse1 – Toujours utiliser le verrou ( après chaque réinitialisation, le modem efface les paramètres précédents, peu importe ce qui est utilisé ici)earfcn de lte infophy-cellid de lte infoMobile code opérateur

Tous les codes PLMN disponibles

ici

cette variable peut également être laissée vide

Pour verrouiller le modem sur la cellule – le modem doit être en état de non-fonctionnement, moyen le plus simple pour

R11e-4G

modem consiste à ajouter la ligne CellLock à la chaîne “modem-init”:

/interface lte set lte1 modem-init=”AT%CLCMD=1,1,3250,244,\”24705\””

Plusieurs cellules peuvent également être ajoutées en fournissant une liste au lieu d’une information de tour au format suivant:

AT%CLCMD=,,,,,,,,

Par exemple, pour verrouiller sur deux PCI différents au sein de la même bande et du même opérateur:

/interface lte set lte1 modem-init=”AT%CLCMD=1,1,6300,384,\”24701\”,6300,385,\”24701\””

Moniteur de cellule

Le moniteur de cellule permet de scanner les cellules disponibles du réseau mobile à proximité:

[admin@MikroTik] > interface lte cellule-moniteur lte1PHY-CELLID BAND EARFCN RSRP RSRQ RSSI 11 B3 1300 -107dBm -175dB 306 B1 150 -115dBm -195dB 373 B3 1300 -111dBm -195dB 374 B3 1300 -111dB 384 B -1 -106dBm -120dB 384 B7 2850 -115dBm -175dB 384 B20 6300 -97dBm -195dB

Les données recueillies peuvent être utilisées pour une détection de localisation plus précise ou pour le verrouillage de cellule.

Dépannage

Activer la journalisation LTE:

[admin@MikroTik] > /system logging add topics=lte

Vérifiez les erreurs dans le journal:

[admin@MikroTik] > /log print11:08:59 lte, async lte1: envoyé AT+CPIN?11:08:59 lte, async lte1 : rcvd + ERREUR CME : 10

rechercher la description de l’erreur CME en ligne,

dans ce cas : erreur CME 10 – SIM non insérée

Bande de verrouillage sur Huawei et autres modems

Pour verrouiller la bande pour les modems Huawei

/interface lte set lte1 band=””

l’option ne peut pas être utilisée.

Il est possible d’utiliser les commandes AT pour verrouiller manuellement la bande souhaitée.

Pour vérifier toutes les bandes prises en charge, exécutez la commande at-chat:

[admin@MikroTik] /interface lte at-chat lte1 input=”AT^SYSCFGEX=\?”sortie: ^SYSCFGEX: (“00″,”03″,”02″,”01″,”99″),( (2000004e80380,”GSM850/GSM900/GSM1800/GSM1900/WCDMA BCI/WCDMA BCII/WCDMA BCV/WCDMA BCVIII”),(3fffffff,”Toutes les bandes”)),(0-2),(0-4),(( 800d7,”LTE BC1/LTE BC2/LTE BC3/LTE BC5/LTE BC7/LTE BC8/LTE BC20″),(7ffffffffffffffff,”Toutes les bandes”)) OK

Exemple pour verrouiller sur la bande LTE 7,

[admin@MikroTik] /interface lte set lte1 modem-init=”AT^SYSCFGEX=\”03\”,3FFFFFFF,2,4,40,,”

Changer la dernière partie

40

à la valeur hexadécimale spécifiée par la bande souhaitée où:

4 LTE BC340 LTE BC780000 LTE BC207FFFFFFFFFFFFFF Toutes les bandes c

Toutes les valeurs HEX de bande et les commandes AT peuvent être trouvées dans

Guide de spécification de l’interface de commande Huawei AT

Vérifiez si la bande est verrouillée:

[admin@MikroTik] /interface lte at-chat lte1 input=”AT^SYSCFGEX\?”sortie: ^SYSCFGEX: “03”,3FFFFFFF,0,2,40OK

Pour plus d’informations, consultez les manuels de référence des commandes AT des fabricants de modems.

Modems mPCIe avec appareils de la série RB9xx

Pour que les modems mPCIe fonctionnent dans les appareils de la série RB9xx, il est nécessaire de définir le type USB sur mPCIe, cela peut être fait à l’aide de la commande suivante:

/system routerboard usb set type=mini-PCIe

Si votre modem n’est pas reconnu après un redémarrage logiciel, vous devrez peut-être ajouter un délai avant l’initialisation du port USB.Cela peut être fait à l’aide de la commande suivante:

/system routerboard settings set init-delay=5s

Mise à niveau du micrologiciel du modem

Avertissement:

Avant de tenter la mise à niveau du micrologiciel du modem LTE – mettez à niveau la version de RouterOS vers les dernières versions

Comment mettre à niveau RouterOS

À partir de RouterOS version 6.44beta20, il est possible de mettre à niveau le firmware des modems.

La mise à jour du micrologiciel est disponible uniquement en tant que micrologiciel FOTA sans fil – la mise à niveau du micrologiciel ne peut être effectuée que via une connexion mobile fonctionnelle pour:

)R11e-LTE

)R11e-LTE-US

Mise à jour du micrologiciel disponible en tant que FOTA et mise à niveau à partir d’un fichier pour:

)R11e-4G

)R11e-LTE6

Les mises à jour du micrologiciel incluent généralement de petites améliorations de stabilité ou de petites corrections de bogues qui ne peuvent pas être incluses dans RouterOS.

Vérifiez la version du micrologiciel actuellement utilisée en exécutant:

[admin@MikroTik] > /interface lte info lte1 une fois—–révision : “MikroTik_CP_2.160.000_v008”—–

Vérifiez si un nouveau firmware est disponible:

[admin@MikroTik] > /interface lte firmware-upgrade lte1 installé : MikroTik_CP_2.160.000_v008 dernier : MikroTik_CP_2.160.000_v010

Mise à niveau du firmware:

[admin@MikroTik] > interface lte firmware-upgrade lte1 upgrade=yes status : téléchargement via connexion LTE (>2min)

L’ensemble du processus de mise à niveau peut prendre jusqu’à 10 minutes, selon la vitesse de la connexion mobile.

Après une mise à niveau réussie, réinitialisez l’alimentation USB, redémarrez l’appareil ou exécutez la commande AT+reset pour mettre à jour la lecture de la version du modem sous la commande info:

[admin@MikroTik] > /interface lte at-chat lte1 input=”AT+reset”

si le modem a des problèmes de connexion aux cellules après la mise à jour, ou s’il y a d’autres problèmes non liés, effacez l’ancienne configuration avec:

/interface lte at-chat lte1 input=”AT+RSTSET”

Éviter la limitation de la vitesse de connexion

Certains opérateurs (TMobile, YOTA, etc.) autorisent des données illimitées uniquement pour l’appareil sur lequel la carte SIM est utilisée, toutes les autres données provenant de points d’accès mobiles ou de partage de connexion sont fortement limitées en volume ou en vitesse de débit.

Quelques sources

ont découvert que cette limitation est effectuée en surveillant les valeurs TTL (Time To Live) des paquets pour déterminer si des limitations doivent être appliquées (TTL est diminué de 1 pour chaque “saut” effectué). RouterOS permet de modifier le paramètre TTL pour les paquets allant du routeur pour permettre de masquer les sous-réseaux.Gardez à l’esprit que cela peut entrer en conflit avec la politique d’utilisation équitable.

/ip firewall mangleadd action=change-ttl chain=postrouting new-ttl=set:65 out-interface=lte1 passthrough=yes

Plus d’information:

YOTA

,

T Mobile

Déverrouillage de la carte SIM après plusieurs tentatives erronées de code PIN

Après avoir verrouillé la carte SIM, le déverrouillage peut être effectué via “at-chat”

Vérifiez l’état actuel du code PIN:

/interface/lte/at-chat lte1 input=”at+cpin\?”

Si la carte est verrouillée, déverrouillez-la en fournissant:

/interface lte at-chat lte1 input=”AT+CPIN=\”PUK_code\”,\”NEW_PIN\””

Remplacez PUK_code et NEW_PIN par les valeurs correspondantes.

[

Sommet

|

Retour au contenu

]

Récupéré de “

http:///https:///wiki.mikrotik.com/index.php?title=Manual:Interface/LTE&oldid=34432

Previous Post Next Post

Leave a Reply

Your email address will not be published. Required fields are marked *